I have been trying to figure out which Python versions are compatible with LEAN CLI and there seems to be missing/contradicting information in the docs/github/pypi.

The docs doesn't seem to refer to any kind of python version requirement:

the docs related to installing LEAN Engine is empty:

However in LEAN github repo under Algorithm.Python this is stated:

“Setup Lean Locally with Python … Installing Python 3.6: … Use the Windows x86-64 MSI Python 3.6.8 installer from python.org or Anaconda for Windows installer. … Install pandas=0.25.3 and its dependencies…”

But then again in the Lean CLI github repo, there is no mention of any Python version requirement:

However on Pypi it is stated as  Requires: Python >= 3.6 


Am I mixing up LEAN CLI vs Engine requirements? If the CLI requirement is just Python ≥3.6, can I backtest a machine learning model trained with a package that requires Python 3.8 work? Any clarification and info is greatly appreciated!


Note: I am thinking of using LEAN only locally. I think there are other package and Python version limitations when using LEAN on QuantConnect Cloud.