Back

Problems with leverage going to 10000

I wrote out something simple that I wouldn't expect to be incredibly successful or unsuccesful, however I got strange results...

The returns failed at a pretty unvolatile rate, so when I made my longs short and shorts long, I got almost the same results...

When I looked at the generated report it was even stranger.

https://i.gyazo.com/1b1f7c6b15ba8b23e4f884482989efe4.png

The leverage was going to over 10,000, I have no idea why. I never let my algo trade unless it had no holdings. So I am extremely puzzled and disgruntled.

Could anyone shed some light on this?

Thanks,

Sean McKenna

Update Backtest








Update Backtest





0

The material on this website is provided for informational purposes only and does not constitute an offer to sell, a solicitation to buy, or a recommendation or endorsement for any security or strategy, nor does it constitute an offer to provide investment advisory services by QuantConnect. In addition, the material offers no opinion with respect to the suitability of any security or specific investment. QuantConnect makes no guarantees as to the accuracy or completeness of the views expressed in the website. The views are subject to change, and may have become unreliable for various reasons, including changes in market conditions or economic circumstances. All investments involve risk, including loss of principal. You should consult with an investment professional before making any investment decisions.


Loading...

This discussion is closed