Back

Error running LEAN (python module)

Hi,

I have tried succesfully to build and run a C# strategy. But when compiling (No errors) and running a Python Strategy QuantConnect.Lean.Launcher.exe exist with code error 1.

I think I have done all the steps indicated in github page but I miss something maybe.

My config is: VS2017 Community + Anaconda + python2.7 with panda package added (I put some capture . Any idea please??

Thanks

Update Backtest








I was having a similar issue where VS would reconize Python but I was still getting an error that Lean could not find the .dll. I tried the above and reinstalled everything with no luck. Howerver, I was able to get it to work by going to Tools > NuGet Package Manager > Manage NuGet Packages for Solution then updated the packages and reinstalled QuantConnect.pythonnet to the entire project. I was able to build it and run a debug with no further issues. I spent many hours trying to figure this out and hope I can save someone else the time and headache!

2

I want to run a python script from within IntelliJ IDEA passing a file list as a parameter. I'm using menu Run->Edit Configurations->Script Parameters to define a file list using wildcards like: "../examples/*.jpg"

Inside the code I'm iterating the file list using a for loop like

for f in sys.argv[1:]:

Although the script executes fine from terminal, IDEA throws a file not found exception:

No such file or directory: '../examples/*.jpg'

I suppose this makes sense (my theory) since there is no shell involved to expand the command line argument into a file list prior passing it to the script.

There is an answer in a similar question here: Pycharm and sys.argv arguments The relevant answer using wildcards is https://stackoverflow.com/a/41003295/7521854 but it is not working. (If I had enough rep I'd commented on this answer, sorry)

Any suggestion will make me happy!

PS: running OSX 10.11.6 (El Capitan)

0

Update Backtest





0

The material on this website is provided for informational purposes only and does not constitute an offer to sell, a solicitation to buy, or a recommendation or endorsement for any security or strategy, nor does it constitute an offer to provide investment advisory services by QuantConnect. In addition, the material offers no opinion with respect to the suitability of any security or specific investment. QuantConnect makes no guarantees as to the accuracy or completeness of the views expressed in the website. The views are subject to change, and may have become unreliable for various reasons, including changes in market conditions or economic circumstances. All investments involve risk, including loss of principal. You should consult with an investment professional before making any investment decisions.


Loading...

This discussion is closed