I made a C# version of the G Score Factor Investing example, but it is flatlining.  I am running it mainly in the web IDE because I don't have real equity data when running locally, except the few days of sample data. I converted it to C# partly so it might run faster, but mainly so I can understand what the Python version is doing.

See  this for the Python version that works.


My diagnosis thus far, when I run my C# locally in Lean CLI mode I see it finding AAPL and IBM

20201119 07:12:31.296 Trace:: Debug: Fine count: 0
20201119 07:12:32.054 Trace:: Debug: Fine count: 5
Fine security: AAPL; 536.72
Fine security: IBM; 192.71
20201119 07:12:32.117 Trace:: Debug: Fine count: 0

However when I run the same code in the web IDE it finds no equities, "Fine count: 0"

11 | 10:14:31:
Launching analysis for 1dba00651430656b724a8e96ebab8b74 with LEAN Engine v2.
12 | 10:14:32:
Fine count: 0
13 | 10:15:27:
Algorithm (1dba00651430656b724a8e96ebab8b74) Completed.

If I solve it I'll post the answer here, otherwise any tips would be very helpful.